Potential bug


#1

FYI: when I make edits I usually get an error message but the edit goes through anyway


#2

What does the error message say?


#3

I’m trying to replicate the error message but I cannot edit my message anymore.

There are probably conditional rules surrounding the edition process (cannot edit after x minute? cannot edit after the first view? cannot edit for xyz reason) that locks down the post while I am still in the edition mode. That is probably why I am receiving the error message.

Test


#4

Ok, replicated the error message.

Edited the message by adding the word “test” at the end. When I tried to “save and exit”, the following message came up. I had to choose “cancel” to exit the contextual menu. The “test” modification came through anyways.

Tried to edit another message by removing a mistake and the same message appeared. This time, however, I could not remove the erroneous word.


#5

@brucesw I remember you had some issue with editing. is that the error you came across? I recall you were somehow able to fix the issue or skirt around it, are you still having this error?


(Bruce) #6

I have been extra careful to proofread before posting, to minimize having to use edit. When I have had to use edit, I get the error message but the edit goes through. I don’t believe I have tried to edit a post more than once. The only way to exit the edit screen is to go back to the home page or leave the site and come back to the thread.

Before I was getting the error message and the edit was not going through.

This was in Firefox. I had no problem in IE. I have not switched over to try an edit in IE recently but there has been some change in the way it works in Firefox.


(John Hartley) #7

I work in Firefox and have always had this error message when editing. I’ve never bothered mentioning it,as it’s not really a problem - I close the box and my edit has worked anyway.


#8

Ok, I can buy that it was developed for IE and that there might be bugs on other platforms. I’m using chrome.

Not all edits have worked for me. Additions and format changes seems to go through but text removal seem to be an issue.

Its a bit of a shame because I have the tendency to let mistakes slip when I write posts. I’ll only “see” them when I read my text and rely on the edit function to make something clean.

There are also some challenges with links to tumblr accounts. The template seem to want to generate a preview but fails and it makes a bit of a mess (it generate a big grey square with an incomplete text. The hyperlink does work though). The “add Hyperlink” function does not seem to make a difference. The link will show a picture if the tumblr page has one but if it doesn’t it will just generate a placeholder.

The generation of preview to tumblr seem also to be a bit random. I’ve posted a lot of links in a single post (see second post of thread Cultural background of Montreal gastronomy) and I’d say about half generated “previews” and the other half just posted the links. The problem does not reproduce itself if I post a series of links to other pages (see SAQ Wine and Spirits ) The preview aspect wasn’t important for me but I do appreciate if a list is consequent and clean.

Overall, its not a dealbreaker. Its just a little less clean than it could be. Maybe using IE might fix my problem?

Here is an exemple of the “preview bug”, using a random link:


#9

the preview generation grabs the first ‘image’ that they can find in the page for the preview image. the issue arises when sometimes they can’t find an image or the image is not the right size, then the preview image shows up funny. In some cases, as you said, it works:

MAPLE-CANDIED BACON INGREDIENTS
• 1 lb. good quality bacon, sliced
• 2 tbsp. pure maple syrup (not pancake syrup)
• ¼ c. brown sugar
• 2 tsp. Dijon mustard
• ½ tsp. Kosher salt
• ¼ tsp cayenne...

in general, in my observation, the earlier a picture is in the URL, the easier it seems to be able to find the pic and use for preview. i won’t say its a bug per se but rather the preview generation is not as “intelligent” as it should be. when that happens, my recommendation is the link button (the fourth icon in the edit window, looks like a chain). Just type some text, highlight the text, click the link button, and then paste the URL. more clunky, yes.

currently the edit time window is set at 1 hr. do you all happen to be editing beyond an hour or are you getting this error within an hour as well?

let me google to see if anyone mentioned anything about the first issue you pointed out.


#10

Hey!

Thanks for the quick feedback. Good to know the edit window is within 1 hour. Its definitely not related to the edit window then (I usually make my edits seconds to minutes after the post). Like I said, there are minor glitches but nothing gamebreaking. Everything will probably be smoother if I start using IE.

Just thought giving some feedback on potential bugs might be interesting!


#11

This is one of those issues that I just can’t duplicate the error message. I am using Firefox, and I know Bruce/ Harters use Firefox and Captcrunch use Chrome. I remember spending quite a bit of time looking at this with Bruce but didn’t find anything. All- do you use any plugins/ addons in your browser? If so, what do you use? Do you do any customization to your browser?

All- next time you run into the issue, can you note the exact time when u got the error- I will take a look at the error log of the site. Thanks.


(John Hartley) #12

Just a test to see if I get the error message, so I can give the time.

(EDIT) Error message came up straight away. 9.59 UK time


#13

Unfortunately the site error log didn’t log anything at that time.


#14

Just made a mistake in a post by adding an extra word:

*Chrome generated an error message and did not delete the extra word.
*Firefox generated an error message and did not delete the extra word
*Internet explorer did not generate an error message and successfully deleted the extra word.

So! If you have edits to do and have a hard time doing it just fire off IE and make sure you finish your edit before your hour window is closed!

The bugs look to be a simple case of a web platform not fully bug tested outside internet explorer.


#15

Which is really odd because IE is like the distant third (or fourth?) after Chrome and Firefox…

Can one of you do me a favor, fire up Firefox without the addons and see if you still get the same problem?

https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode#w_how-to-start-firefox-in-safe-mode

I asked because I don’t get the same errors.