Incomplete Search Results and Latest Sort / Date filters not working - bug or user error ?

I was looking for my own WFD posts to find something.

However only a small subset of my posts appeared as the result.

The same has happened when I’ve searched before - and in those cases, despite sorting results by “Latest,” they are mixed up in chronology.

Here is the search I just used - by user, discussion (cooking) and tag (wfd) - only 3 Sep posts appear, and a smattering from prior months:

Here are the results when I just search in the Sep thread - you can see how the order is mixed up despite sorting by “Latest”

It appears something is wrong with the date selection and sort generally - here I filtered for posts AFTER Sep 15, and you can see the results include Sep 7 and so on:

Let me ask around the dev’s forum to see how we should be searching for this purpose. I tried the search and i did even worse than you- only one results returned.

thank you

Interestingly I looked at the search results from these two links and the results seem to be correct now. Maybe the search index takes some time to get it right?

For this, however, its only returning the latest of your posts from each WFD discussion you participated.

I posed the question in the dev support forum a few days ago but didn’t hear back. Let me post the updated, narrowed question on why the results only return one post per forum.

Revisiting this question. Just had incomplete search results again - was looking for my own posts in the FWD thread.

The developer’s response: Enter the discussion and search for @me within that particular topic.

nope, tried that before I posted. thanks, though.

Same search issue again: